Mostly the GCC10 yylloc failure was seen but several others have been observed: * wireguard script was silently failing * several gcc10 x86 errors * a checksum from kernel.org has changed Now we have 3 different gcc10 yylloc patches: gcc10-extern_YYLOC_global_declaration.patch: Linux < 4.2 linux4.2-gcc10-extern_YYLOC_global_declaration.patch: Linux 4.2+ linux4.17-gcc10-extern_YYLOC_global_declaration.patch: Linux 4.17+ [ci:skip-build] [ci:ignore-count] [ci:skip-vercheck]
41 lines
1.4 KiB
Diff
41 lines
1.4 KiB
Diff
From df6d4f9db79c1a5d6f48b59db35ccd1e9ff9adfc Mon Sep 17 00:00:00 2001
|
|
From: "H.J. Lu" <hjl.tools@gmail.com>
|
|
Date: Thu, 16 Jan 2020 12:46:51 -0800
|
|
Subject: [PATCH] x86/boot/compressed: Don't declare __force_order in
|
|
kaslr_64.c
|
|
|
|
GCC 10 changed the default to -fno-common, which leads to
|
|
|
|
LD arch/x86/boot/compressed/vmlinux
|
|
ld: arch/x86/boot/compressed/pgtable_64.o:(.bss+0x0): multiple definition of `__force_order'; \
|
|
arch/x86/boot/compressed/kaslr_64.o:(.bss+0x0): first defined here
|
|
make[2]: *** [arch/x86/boot/compressed/Makefile:119: arch/x86/boot/compressed/vmlinux] Error 1
|
|
|
|
Since __force_order is already provided in pgtable_64.c, there is no
|
|
need to declare __force_order in kaslr_64.c.
|
|
|
|
Signed-off-by: H.J. Lu <hjl.tools@gmail.com>
|
|
Signed-off-by: Borislav Petkov <bp@suse.de>
|
|
Link: https://lkml.kernel.org/r/20200124181811.4780-1-hjl.tools@gmail.com
|
|
---
|
|
arch/x86/boot/compressed/kaslr_64.c | 3 ---
|
|
1 file changed, 3 deletions(-)
|
|
|
|
diff --git a/arch/x86/boot/compressed/kaslr_64.c b/arch/x86/boot/compressed/kaslr_64.c
|
|
index 748456c365f4..9557c5a15b91 100644
|
|
--- a/arch/x86/boot/compressed/kaslr_64.c
|
|
+++ b/arch/x86/boot/compressed/kaslr_64.c
|
|
@@ -29,9 +29,6 @@
|
|
#define __PAGE_OFFSET __PAGE_OFFSET_BASE
|
|
#include "../../mm/ident_map.c"
|
|
|
|
-/* Used by pgtable.h asm code to force instruction serialization. */
|
|
-unsigned long __force_order;
|
|
-
|
|
/* Used to track our page table allocation area. */
|
|
struct alloc_pgt_data {
|
|
unsigned char *pgt_buf;
|
|
--
|
|
2.29.2
|
|
|