This adds the wlr and GTK portal backends so that apps using portals will work OOTB. The GTK backend is added because the wlr backend does not provide some essential portals, e.g. for camera [ci:skip-build]: already built successfully in CI
71 lines
1.6 KiB
Plaintext
71 lines
1.6 KiB
Plaintext
# Reference: https://postmarketos.org/uipkg
|
|
# Maintainer: Oliver Smith <ollieparanoid@postmarketos.org>
|
|
pkgname=postmarketos-ui-sway
|
|
pkgver=3.1
|
|
pkgrel=8
|
|
pkgdesc="(Wayland) Tiling WM, drop-in replacement for i3wm (DOES NOT RUN WITHOUT HW ACCELERATION!)"
|
|
url="https://postmarketos.org"
|
|
arch="noarch"
|
|
license="GPL-3.0-or-later"
|
|
subpackages="$pkgname-openrc $pkgname-logo-key-alt:logo_key_alt"
|
|
depends="
|
|
bluez
|
|
dnsmasq
|
|
elogind
|
|
polkit-elogind
|
|
postmarketos-base-ui
|
|
postmarketos-base-ui-networkmanager
|
|
sway
|
|
swaybg
|
|
tinydm
|
|
xdg-desktop-portal-gtk
|
|
xdg-desktop-portal-wlr
|
|
"
|
|
_pmb_recommends="
|
|
dmenu
|
|
foot
|
|
postmarketos-artwork-wallpapers
|
|
swayidle
|
|
swaylock
|
|
xwayland
|
|
"
|
|
_pmb_groups="
|
|
seat
|
|
"
|
|
source="
|
|
etc-sway-config
|
|
etc-sway-config.d-00-logo-key.conf
|
|
"
|
|
options="!check pmb:gpu-accel" # no testsuite
|
|
replaces="sway"
|
|
|
|
package() {
|
|
install -Dm644 "$srcdir"/etc-sway-config \
|
|
"$pkgdir"/etc/sway/config
|
|
}
|
|
|
|
logo_key_alt() {
|
|
install -Dm644 "$srcdir"/etc-sway-config.d-00-logo-key.conf \
|
|
"$subpkgdir"/etc/sway/config.d/00-logo-key.conf
|
|
}
|
|
|
|
openrc() {
|
|
install_if="$pkgname=$pkgver-r$pkgrel openrc"
|
|
install="$subpkgname.post-install $subpkgname.post-upgrade"
|
|
depends="
|
|
bluez-openrc
|
|
elogind-openrc
|
|
modemmanager-openrc
|
|
networkmanager-openrc
|
|
seatd-openrc
|
|
tinydm-openrc
|
|
"
|
|
|
|
mkdir -p "$subpkgdir"
|
|
}
|
|
|
|
sha512sums="
|
|
6caaaa313d509a54eaa43e6bc24739f5d8241689dbed268885f6645e79567e3cd9f41d0d8fa43d52fe99587a1d1b6f1669cfecc88220d9ea409feb4f4cd43d3c etc-sway-config
|
|
889f10fb247396a11375057f7e81eae0f0b21ec90cd47964e02ba24fc0f6db8bb7678545e3272149535cf0bb6a2019456cc59d06a9564ce4a1797bb434013b78 etc-sway-config.d-00-logo-key.conf
|
|
"
|