pmaports-a71/main/postmarketos-installkernel/APKBUILD
Clayton Craft 5541f19df4
main/postmarketos-installkernel: install to /sbin (MR 5728)
This reverts 622140965c, which basically broke installkenrel because
the kernel build system is hardcoded to look for installkernel in /
sbin/installkernel.

We'll have to move then once usr merge is complete and the symlink is
created for /sbin
[ci:skip-build]: already built successfully in CI
2024-10-22 23:21:23 -07:00

29 lines
894 B
Plaintext

# Maintainer: Minecrell <minecrell@minecrell.net>
# Co-Maintainer: Alexey Minnekhanov <alexeymin@postmarketos.org>
# APKBUILD is inspired by Alpine's:
# https://gitlab.alpinelinux.org/alpine/aports/-/tree/master/main/installkernel
pkgname=postmarketos-installkernel
pkgver=0.1
pkgrel=3
pkgdesc="postmarketOS script for installing mainline kernels"
url="https://gitlab.postmarketos.org/postmarketOS/pmaports/tree/main/postmarketos-installkernel"
arch="noarch"
license="GPL-2.0"
options="!check" # no test suite
provides="installkernel=3.5-r1"
provider_priority=100
replaces="installkernel"
source="installkernel-pmos"
build() {
return 0
}
package() {
install -Dm755 "$srcdir"/installkernel-pmos "$pkgdir"/sbin/installkernel
}
sha512sums="
ba3bdb2d27f7b866a49354fcc4b83ec85747a71265c6b585cb062fc1ff00e88faeba7b77f463d6699e81685c8927ee1d316d5934f374aeebfd4949007d8cb4d8 installkernel-pmos
"