32 lines
850 B
Plaintext
32 lines
850 B
Plaintext
# Maintainer: Craig Comstock <craig@unreasonablefarm.org>
|
|
pkgname=gesture
|
|
pkgver=0.7
|
|
pkgrel=1
|
|
pkgdesc="handwriting algorithm with implementation for linux touchscreens injecting keys into a tty"
|
|
url="https://gitlab.com/unrznbl/gesture"
|
|
arch="all"
|
|
license="GPL-3.0-only"
|
|
makedepends="linux-headers"
|
|
options="!check"
|
|
source="https://gitlab.com/unrznbl/gesture/-/archive/v$pkgver/gesture-v$pkgver.tar.gz"
|
|
subpackages="$pkgname-openrc"
|
|
builddir="$srcdir/gesture-v$pkgver"
|
|
|
|
build() {
|
|
make all
|
|
}
|
|
|
|
package() {
|
|
make DESTDIR="$pkgdir" install
|
|
}
|
|
|
|
openrc() {
|
|
install_if="$pkgname=$pkgver-r$pkgrel openrc"
|
|
install="$subpkgname.post-install $subpkgname.pre-deinstall"
|
|
mkdir -p "$subpkgdir"
|
|
}
|
|
|
|
sha512sums="
|
|
f05eae4dded079eed6fd7b362485bec6400f18f4e9cf2a42ee80a378d0f9de7d85b8afc5671a349f5dee85ea92b1281415158ae85abd160668ad13aa8e3a46a1 gesture-v0.7.tar.gz
|
|
"
|