pmaports-a71/device/testing/linux-postmarketos-qcom-sdm660/APKBUILD
Alexey Min 5da8f081d5
linux-postmarketos-qcom-sdm660: upgrade to 6.11.1 (MR 5702)
This release has several little but neat fixes not really worth
mentioning, but most notable features are:

* Xiaomi Mi PAD 4 and PLUS (clover) *both* now have proper panel
  driver and full GPU support. On par with other our devices now.
  Thanks to @kubntd for code and @barni2000 for testing !
* ath10k wlan no-msa-indication hack was dropped in favor of
  solution that was accepted upstream.
* Adreno 5xx preemption fixes were also included.
2024-10-17 03:49:30 +03:00

70 lines
1.8 KiB
Plaintext

# Maintainer: Alexey Minnekhanov <alexeymin@postmarketos.org>
# Kernel config based on: arch/arm64/configs/sdm660_defconfig
_flavor="postmarketos-qcom-sdm660"
pkgname=linux-$_flavor
pkgver=6.11.1
pkgrel=0
pkgdesc="Close to mainline linux kernel for Qualcomm Snapdragon 660 SoC"
arch="aarch64"
url="https://kernel.org/"
license="GPL-2.0-only"
options="!strip !check !tracedeps
pmb:cross-native
pmb:kconfigcheck-community
"
makedepends="
bash
bison
findutils
flex
openssl-dev
perl
postmarketos-installkernel
python3
zstd
"
_tag="v$pkgver-sdm660"
source="
linux-$_tag.tar.gz::https://github.com/sdm660-mainline/linux/archive/refs/tags/$_tag.tar.gz
config-$_flavor.aarch64
"
_carch="arm64"
# for some reason, the directory inside .tar.gz does not match tag name: leading
# "v" is missing, so we can't use $_tag here
builddir="$srcdir/linux-$pkgver-sdm660"
prepare() {
default_prepare
cp -v "$srcdir/config-$_flavor.$CARCH" "$builddir"/.config
}
build() {
unset LDFLAGS
make ARCH="$_carch" CC="${CC:-gcc}" \
KBUILD_BUILD_VERSION="$((pkgrel + 1 ))-$_flavor"
}
package() {
mkdir -p "$pkgdir"/boot
make zinstall modules_install dtbs_install \
ARCH="$_carch" \
INSTALL_PATH="$pkgdir"/boot \
INSTALL_MOD_PATH="$pkgdir" \
INSTALL_MOD_STRIP=1 \
INSTALL_DTBS_PATH="$pkgdir/boot/dtbs"
rm -f "$pkgdir"/lib/modules/*/build "$pkgdir"/lib/modules/*/source
install -D "$builddir/include/config/kernel.release" \
"$pkgdir/usr/share/kernel/$_flavor/kernel.release"
}
sha512sums="
c51fad438eabd6023d0b667f7c0c13fef776565c6e67fe14b9dd2e0c23d5903ac8a91d29ac5411d52e6de7128ea303c08d3a1518cc21aafa958761455b5ca848 linux-v6.11.1-sdm660.tar.gz
a51a7ceab5cde413750f8140412c17844257bf538ec17a48ab5bc4130e9fbb18225a43e9c9dfce10750c000091d921bbc494bc4f8381d4ce85c0630c9a1f281d config-postmarketos-qcom-sdm660.aarch64
"