htc-golfu: new device (MR 1824)
[ci:skip-build]: already built successfully in CI
This commit is contained in:
parent
3a09499708
commit
f85d5fa3fd
24
device/testing/device-htc-golfu/APKBUILD
Normal file
24
device/testing/device-htc-golfu/APKBUILD
Normal file
|
@ -0,0 +1,24 @@
|
||||||
|
# Reference: <https://postmarketos.org/devicepkg>
|
||||||
|
# Maintainer: Newbyte <newbytee@protonmail.com>
|
||||||
|
pkgname=device-htc-golfu
|
||||||
|
pkgdesc="HTC Desire C"
|
||||||
|
pkgver=0.1
|
||||||
|
pkgrel=0
|
||||||
|
url="https://postmarketos.org"
|
||||||
|
license="MIT"
|
||||||
|
arch="armv7"
|
||||||
|
options="!check !archcheck"
|
||||||
|
# mdss-fb-init-hack: screen stays black on boot without this
|
||||||
|
depends="postmarketos-base linux-htc-golfu mkbootimg mdss-fb-init-hack mesa-dri-gallium"
|
||||||
|
makedepends="devicepkg-dev"
|
||||||
|
source="deviceinfo"
|
||||||
|
|
||||||
|
build() {
|
||||||
|
devicepkg_build $startdir $pkgname
|
||||||
|
}
|
||||||
|
|
||||||
|
package() {
|
||||||
|
devicepkg_package $startdir $pkgname
|
||||||
|
}
|
||||||
|
|
||||||
|
sha512sums="fd3db7b26a624e088a436b9ee6a87db9c748d7259aeae188686c8080b2470eaed6bcbf941b90ecbf2f629151f58b2bc635e544f3debf2ee393615c837b937c7a deviceinfo"
|
33
device/testing/device-htc-golfu/deviceinfo
Normal file
33
device/testing/device-htc-golfu/deviceinfo
Normal file
|
@ -0,0 +1,33 @@
|
||||||
|
# Reference: <https://postmarketos.org/deviceinfo>
|
||||||
|
# Please use double quotes only. You can source this file in shell
|
||||||
|
# scripts.
|
||||||
|
|
||||||
|
deviceinfo_format_version="0"
|
||||||
|
deviceinfo_name="HTC Desire C"
|
||||||
|
deviceinfo_manufacturer="HTC"
|
||||||
|
deviceinfo_codename="htc-golfu"
|
||||||
|
deviceinfo_year="2012"
|
||||||
|
deviceinfo_modules_initfs=""
|
||||||
|
deviceinfo_arch="armv7"
|
||||||
|
|
||||||
|
# Device related
|
||||||
|
deviceinfo_chassis="handset"
|
||||||
|
deviceinfo_keyboard="false"
|
||||||
|
deviceinfo_external_storage="true"
|
||||||
|
deviceinfo_screen_width="320"
|
||||||
|
deviceinfo_screen_height="480"
|
||||||
|
|
||||||
|
# Bootloader related
|
||||||
|
# Stock setup has no_console_suspend=1 console=null part of cmdline, but device
|
||||||
|
# seems to work fine without this.
|
||||||
|
deviceinfo_flash_method="fastboot"
|
||||||
|
deviceinfo_generate_bootimg="true"
|
||||||
|
deviceinfo_bootimg_qcdt="false"
|
||||||
|
deviceinfo_bootimg_mtk_mkimage="false"
|
||||||
|
deviceinfo_bootimg_dtb_second="false"
|
||||||
|
deviceinfo_flash_offset_base="0x13000000"
|
||||||
|
deviceinfo_flash_offset_kernel="0x00008000"
|
||||||
|
deviceinfo_flash_offset_ramdisk="0x01000000"
|
||||||
|
deviceinfo_flash_offset_second="0x00f00000"
|
||||||
|
deviceinfo_flash_offset_tags="0x00000100"
|
||||||
|
deviceinfo_flash_pagesize="4096"
|
60
device/testing/linux-htc-golfu/APKBUILD
Normal file
60
device/testing/linux-htc-golfu/APKBUILD
Normal file
|
@ -0,0 +1,60 @@
|
||||||
|
# Reference: <https://postmarketos.org/vendorkernel>
|
||||||
|
# Kernel config based on: arch/arm/configs/golfu_defconfig
|
||||||
|
|
||||||
|
pkgname=linux-htc-golfu
|
||||||
|
pkgver=3.0.16
|
||||||
|
pkgrel=0
|
||||||
|
pkgdesc="HTC Desire C kernel fork"
|
||||||
|
arch="armv7"
|
||||||
|
_carch="arm"
|
||||||
|
_flavor="htc-golfu"
|
||||||
|
url="https://kernel.org"
|
||||||
|
license="GPL-2.0-only"
|
||||||
|
options="!strip !check !tracedeps pmb:cross-native"
|
||||||
|
makedepends="bash bc bison devicepkg-dev flex gcc6 openssl-dev perl"
|
||||||
|
|
||||||
|
# Compiler: GCC 6 (doesn't boot when compiled with newer versions)
|
||||||
|
if [ "${CC:0:5}" != "gcc6-" ]; then
|
||||||
|
CC="gcc6-$CC"
|
||||||
|
HOSTCC="gcc6-gcc"
|
||||||
|
CROSS_COMPILE="gcc6-$CROSS_COMPILE"
|
||||||
|
fi
|
||||||
|
|
||||||
|
# Source
|
||||||
|
_repository="android_kernel_htc_golfu"
|
||||||
|
_commit="9978ea963a0c33dc1b232425a7eb85a7e9d47124"
|
||||||
|
_config="config-$_flavor.$arch"
|
||||||
|
source="
|
||||||
|
$pkgname-$_commit.tar.gz::https://github.com/Newbytee/$_repository/archive/$_commit.tar.gz
|
||||||
|
$_config
|
||||||
|
gcc7-give-up-on-ilog2-const-optimizations.patch
|
||||||
|
gcc8-fix-put-user.patch
|
||||||
|
gcc10-extern_YYLOC_global_declaration.patch
|
||||||
|
kernel-use-the-gnu89-standard-explicitly.patch
|
||||||
|
timeconst.pl-Eliminate-Perl-warning.patch
|
||||||
|
"
|
||||||
|
builddir="$srcdir/$_repository-$_commit"
|
||||||
|
_outdir="out"
|
||||||
|
|
||||||
|
prepare() {
|
||||||
|
default_prepare
|
||||||
|
. downstreamkernel_prepare
|
||||||
|
}
|
||||||
|
|
||||||
|
build() {
|
||||||
|
unset LDFLAGS
|
||||||
|
make O="$_outdir" ARCH="$_carch" CC="${CC:-gcc}" \
|
||||||
|
KBUILD_BUILD_VERSION="$((pkgrel + 1 ))-postmarketOS"
|
||||||
|
}
|
||||||
|
|
||||||
|
package() {
|
||||||
|
downstreamkernel_package "$builddir" "$pkgdir" "$_carch" "$_flavor" "$_outdir"
|
||||||
|
}
|
||||||
|
|
||||||
|
sha512sums="fb6d2905d58958a516e5aaefa32b481c06f747599a117743506545dbfcb82dd6dd4cf4efad11c6e3812f2d0c83ffaa04d935059466843654b282e6170286b295 linux-htc-golfu-9978ea963a0c33dc1b232425a7eb85a7e9d47124.tar.gz
|
||||||
|
81ba3ba8ec23a00edbbfc7825bbe929bd31117e73279a9450086a15c43f85239e214afcd5f9e655e37174227d399c30021d339957633fb278e9c0ae78f3fdc71 config-htc-golfu.armv7
|
||||||
|
77eba606a71eafb36c32e9c5fe5e77f5e4746caac292440d9fb720763d766074a964db1c12bc76fe583c5d1a5c864219c59941f5e53adad182dbc70bf2bc14a7 gcc7-give-up-on-ilog2-const-optimizations.patch
|
||||||
|
197d40a214ada87fcb2dfc0ae4911704b9a93354b75179cd6b4aadbb627a37ec262cf516921c84a8b1806809b70a7b440cdc8310a4a55fca5d2c0baa988e3967 gcc8-fix-put-user.patch
|
||||||
|
2b48f1bf0e3f70703d2cdafc47d5e615cc7c56c70bec56b2e3297d3fa4a7a1321d649a8679614553dde8fe52ff1051dae38d5990e3744c9ca986d92187dcdbeb gcc10-extern_YYLOC_global_declaration.patch
|
||||||
|
ad0182a483791fc88e058838bc331b2f04a75ba291e763767babdb815efadfc3b4fda97e69e2e3f00a426cabea088e35297a92bd287592597d1e309be68ee92c kernel-use-the-gnu89-standard-explicitly.patch
|
||||||
|
1fcfb5f06a2bfdcc55d53054ca80d1b989599a39a5379d057a0724fc405187d74da4309a650e70b9c79d39444e81923cfc5c9199ed8c0a77c83dcd7998446bb7 timeconst.pl-Eliminate-Perl-warning.patch"
|
2583
device/testing/linux-htc-golfu/config-htc-golfu.armv7
Normal file
2583
device/testing/linux-htc-golfu/config-htc-golfu.armv7
Normal file
File diff suppressed because it is too large
Load Diff
|
@ -0,0 +1 @@
|
||||||
|
../../.shared-patches/linux/gcc10-extern_YYLOC_global_declaration.patch
|
|
@ -0,0 +1 @@
|
||||||
|
../../.shared-patches/linux/gcc7-give-up-on-ilog2-const-optimizations.patch
|
1
device/testing/linux-htc-golfu/gcc8-fix-put-user.patch
Symbolic link
1
device/testing/linux-htc-golfu/gcc8-fix-put-user.patch
Symbolic link
|
@ -0,0 +1 @@
|
||||||
|
../../.shared-patches/linux/gcc8-fix-put-user.patch
|
|
@ -0,0 +1 @@
|
||||||
|
../../.shared-patches/linux/kernel-use-the-gnu89-standard-explicitly.patch
|
|
@ -0,0 +1,42 @@
|
||||||
|
From 63a3f603413ffe82ad775f2d62a5afff87fd94a0 Mon Sep 17 00:00:00 2001
|
||||||
|
From: "H. Peter Anvin" <hpa@linux.intel.com>
|
||||||
|
Date: Thu, 7 Feb 2013 17:14:08 -0800
|
||||||
|
Subject: [PATCH] timeconst.pl: Eliminate Perl warning
|
||||||
|
|
||||||
|
defined(@array) is deprecated in Perl and gives off a warning.
|
||||||
|
Restructure the code to remove that warning.
|
||||||
|
|
||||||
|
[ hpa: it would be interesting to revert to the timeconst.bc script.
|
||||||
|
It appears that the failures reported by akpm during testing of
|
||||||
|
that script was due to a known broken version of make, not a problem
|
||||||
|
with bc. The Makefile rules could probably be restructured to avoid
|
||||||
|
the make bug, or it is probably old enough that it doesn't matter. ]
|
||||||
|
|
||||||
|
Reported-by: Andi Kleen <ak@linux.intel.com>
|
||||||
|
Signed-off-by: H. Peter Anvin <hpa@linux.intel.com>
|
||||||
|
Cc: Andrew Morton <akpm@linux-foundation.org>
|
||||||
|
Cc: <stable@vger.kernel.org>
|
||||||
|
---
|
||||||
|
kernel/timeconst.pl | 6 ++----
|
||||||
|
1 file changed, 2 insertions(+), 4 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/kernel/timeconst.pl b/kernel/timeconst.pl
|
||||||
|
index eb51d76e058a..3f42652a6a37 100644
|
||||||
|
--- a/kernel/timeconst.pl
|
||||||
|
+++ b/kernel/timeconst.pl
|
||||||
|
@@ -369,10 +369,8 @@ if ($hz eq '--can') {
|
||||||
|
die "Usage: $0 HZ\n";
|
||||||
|
}
|
||||||
|
|
||||||
|
- @val = @{$canned_values{$hz}};
|
||||||
|
- if (!defined(@val)) {
|
||||||
|
- @val = compute_values($hz);
|
||||||
|
- }
|
||||||
|
+ $cv = $canned_values{$hz};
|
||||||
|
+ @val = defined($cv) ? @$cv : compute_values($hz);
|
||||||
|
output($hz, @val);
|
||||||
|
}
|
||||||
|
exit 0;
|
||||||
|
--
|
||||||
|
2.29.2
|
||||||
|
|
Loading…
Reference in New Issue
Block a user