linux-postmarketos-qcom-msm8974: fix samsung-hlte missing from Makefile (MR 5536)

In the 6.9 branch during development and rebasing this chunk seems to
have disappeared. Since 6.10 msm8974 release is coming probably not
super soon, patch it now so hlte gets its dts back.
This commit is contained in:
Luca Weiss 2024-08-27 12:13:21 +02:00 committed by Alexey Min
parent dc430f8a21
commit e145309671
No known key found for this signature in database
GPG Key ID: 0B19D2A65870B448
2 changed files with 15 additions and 1 deletions

View File

@ -5,7 +5,7 @@ _config="config-$_flavor.$CARCH"
pkgname=linux-$_flavor
pkgver=6.9.1
pkgrel=1
pkgrel=2
_tag="v${pkgver/_/-}-msm8974"
pkgdesc="Kernel close to mainline with extra patches for Qualcomm MSM8974 devices"
arch="armv7"
@ -30,6 +30,7 @@ makedepends="
"
source="
linux-$_tag.tar.gz::https://github.com/msm8974-mainline/linux/archive/refs/tags/$_tag.tar.gz
hlte-makefile.patch
config-$_flavor.armv7
"
builddir="$srcdir/linux-${_tag#v}"
@ -61,5 +62,6 @@ package() {
sha512sums="
34b5b1e94bc333df301efd156980b09814b633069aa890e43bd2e5102c2a4bcafbcc758db359e50d96447f9de81be68456fba6749e894e5c8768975329f7a948 linux-v6.9.1-msm8974.tar.gz
25bdaca920e5990ed46fb84017eaaef16ff61a7564cece35c614653105252a020b24ce8b0f64e1c2f19c58f5ad5c2527811e8c85e2bbd278653bb82a9aa50b05 hlte-makefile.patch
2d561ba93e6efe787e35d3cfa056cb47140fe0502af2d333d84bbeb40146f9b58520c16c90efc4eb7ec575e3c48eeef0102e03f7c3d416fa26472230265443e0 config-postmarketos-qcom-msm8974.armv7
"

View File

@ -0,0 +1,12 @@
diff --git a/arch/arm/boot/dts/qcom/Makefile b/arch/arm/boot/dts/qcom/Makefile
index ede704dabaa1..e17dba6677d0 100644
--- a/arch/arm/boot/dts/qcom/Makefile
+++ b/arch/arm/boot/dts/qcom/Makefile
@@ -40,6 +40,7 @@ dtb-$(CONFIG_ARCH_QCOM) += \
qcom-msm8960-cdp.dtb \
qcom-msm8960-samsung-expressatt.dtb \
qcom-msm8974-lge-nexus5-hammerhead.dtb \
+ qcom-msm8974-samsung-hlte.dtb \
qcom-msm8974-sony-xperia-rhine-amami.dtb \
qcom-msm8974-sony-xperia-rhine-honami.dtb \
qcom-msm8974-sony-xperia-sirius.dtb \