From 5664c3237ca1d9f22b384a997cfb02facde72ed7 Mon Sep 17 00:00:00 2001
From: Stefan Hansson <newbyte@postmarketos.org>
Date: Wed, 31 Jul 2024 11:45:12 +0200
Subject: [PATCH] linux-postmarketos-qcom-sm7150: enable zstd firmware
 compression support (MR 5447)

See https://gitlab.com/postmarketOS/pmaports/-/merge_requests/5380

[ci:skip-build]: already built successfully in CI
---
 device/testing/linux-postmarketos-qcom-sm7150/APKBUILD |  4 ++--
 .../config-postmarketos-qcom-sm7150.aarch64            | 10 ++++++----
 2 files changed, 8 insertions(+), 6 deletions(-)

diff --git a/device/testing/linux-postmarketos-qcom-sm7150/APKBUILD b/device/testing/linux-postmarketos-qcom-sm7150/APKBUILD
index 47a02a198..539e2b529 100644
--- a/device/testing/linux-postmarketos-qcom-sm7150/APKBUILD
+++ b/device/testing/linux-postmarketos-qcom-sm7150/APKBUILD
@@ -5,7 +5,7 @@
 _flavor="postmarketos-qcom-sm7150"
 pkgname=linux-$_flavor
 pkgver=6.7.4
-pkgrel=1
+pkgrel=2
 _pkgrel=0
 pkgdesc="Mainline Kernel fork for SM7150 devices"
 arch="aarch64"
@@ -55,5 +55,5 @@ package() {
 
 sha512sums="
 e5159ef56d28f2e4cc071801c82255d8aa047cc9066aa491ac5a7094eae4b08ec217c042b166cf081e34292b1b6ff957d86545e590d585f3d9516020a37cfb8c  linux-postmarketos-qcom-sm7150-v6.7.4-r0.tar.gz
-e20fbfd096a261a558dd7195d1dbe1148fca86774ae7cd21597b275074aaeba998a449d0547b84cd22a467ba8900856161bd01f06fd4054a1cdf66ab5482ec9d  config-postmarketos-qcom-sm7150.aarch64
+423638d01da98dc7c9358c35c0d7813b8c58a922a9e5ffb3433675bc0ab8687661aaef5e7c279e14b06c7c18ad993b4a91aabaf5336f6da64e14878ba8c43477  config-postmarketos-qcom-sm7150.aarch64
 "
diff --git a/device/testing/linux-postmarketos-qcom-sm7150/config-postmarketos-qcom-sm7150.aarch64 b/device/testing/linux-postmarketos-qcom-sm7150/config-postmarketos-qcom-sm7150.aarch64
index 1f332dfb6..e6ef81163 100644
--- a/device/testing/linux-postmarketos-qcom-sm7150/config-postmarketos-qcom-sm7150.aarch64
+++ b/device/testing/linux-postmarketos-qcom-sm7150/config-postmarketos-qcom-sm7150.aarch64
@@ -2,14 +2,14 @@
 # Automatically generated file; DO NOT EDIT.
 # Linux/arm64 6.7.4 Kernel Configuration
 #
-CONFIG_CC_VERSION_TEXT="aarch64-alpine-linux-musl-gcc (Alpine 13.2.1_git20231014) 13.2.1 20231014"
+CONFIG_CC_VERSION_TEXT="aarch64-alpine-linux-musl-gcc (Alpine 13.2.1_git20240309) 13.2.1 20240309"
 CONFIG_CC_IS_GCC=y
 CONFIG_GCC_VERSION=130201
 CONFIG_CLANG_VERSION=0
 CONFIG_AS_IS_GNU=y
-CONFIG_AS_VERSION=24100
+CONFIG_AS_VERSION=24200
 CONFIG_LD_IS_BFD=y
-CONFIG_LD_VERSION=24100
+CONFIG_LD_VERSION=24200
 CONFIG_LLD_VERSION=0
 CONFIG_CC_HAS_ASM_GOTO_OUTPUT=y
 CONFIG_CC_HAS_ASM_GOTO_TIED_OUTPUT=y
@@ -1661,7 +1661,9 @@ CONFIG_PREVENT_FIRMWARE_BUILD=y
 CONFIG_FW_LOADER=y
 CONFIG_EXTRA_FIRMWARE=""
 # CONFIG_FW_LOADER_USER_HELPER is not set
-# CONFIG_FW_LOADER_COMPRESS is not set
+CONFIG_FW_LOADER_COMPRESS=y
+# CONFIG_FW_LOADER_COMPRESS_XZ is not set
+CONFIG_FW_LOADER_COMPRESS_ZSTD=y
 CONFIG_FW_CACHE=y
 # CONFIG_FW_UPLOAD is not set
 # end of Firmware loader